본문 바로가기
┌Gadget Central

EOS RP Not turning off solution/ EOS RP 안꺼짐 문제

by puercaeli 2022. 9. 4.

 

 

EOS RP, based on 6D Mark II sensor, is now has been on the market for close to 4 years. My personal unit is approaching 3 years old this year. I have not had much issues with aging Canon camera before - but this time I was not so lucky. During my recent trip, I noticed that my EOS RP was turning itself on(or not turning off properly). This poor lens was keep going on and off in by bag ! 

As lens I was using was fairly new, I suspected this may be to do with the lens. So I have tried the other lens I had - however the issue persisted. Naturally, I did a search on various forum posts and recommended solutions ranging from - updating firmware, getting a new battery etc. None of these seemed to work.


From https://community.usa.canon.com/t5/EOS-DSLR-Mirrorless-Cameras/EOS-RP-Issue-Turns-ON-by-itself/td-p/340237

04/20/2021 UPDATE (for Canon techs): 
- The issue is present with / without the accessories (i.e. lens) attached.
- Tried removing the battery for a few days, and putting it back in. Issue still persists.
- If you insert the battery back in (with the SD card), it starts flickering again. Likewise, if you press the shutter button, it turns ON even though the dial is OFF. 
- I've tried hard resetting to factory defaults. Didn't solve the problem.
- Updated firmware, still not solved. 

None of these worked

So I found the below website that explained how to disassemble EOS RP:

https://kolarivision.com/the-canon-eos-rp-disassembly-and-teardown/

Initially, I have done a 'light' tear down where I essentially just tore down the back panel and kept the electronic viewfinder etc in their place. Then I tried to 'claen' the space below the rotating power switch by blowing air etc. This did not fix the problem. Few days ago, I finally had time to do a deeper teardown. I took EVF out and also removed the main power board assembly. 

This is what EOS RP looks like with the back panel removed(ie 'light' tear down). You need to remove EVF and green mainboard to get an access to the power switch area(top left)

My theories for the cause of this issue at this stage were:

1) Somethign to do with little switch around the battery door

2) The power switch problem 

3) Short circuit -?todo with USB C port given I was using USB C charging a lot and proximity to the power button.

No 1 was excluded when I noticed that even manually compressing on this switch still did not resolve the issue. No 2 and 3 possibilities were examined through this tear-down. USB C port is directly soldiered onto EOS RP and there was no crossing between USB C and power switch. - so this became a lot less likley.

Final possibility was that of an inherent switch issue. I have attempted to remove the power switch assembly. There were few switches holding the assembly - about 3-4 screws. However, there were multiple membrane cables passing this area and these adhered to the casing. So I have inspected that power switch - The switch itseld seemd intact with no broken parts and proper rotation.

Then I noticed that the power switch on EOS RP is essentially two separate components. There is a little (very small) arc-shaped switch which is the electrical switch. And what triggers this is a rotating dial assembly that the user actually interacts with. In summary, the dial itself does not actually contain electrical parts - it has a plastic part that simply depresses/unpress the switch. Sadly, the default position of this electrical switch(ie unpressed) turns camera on - hence broken switch defaults to the camera being left one

This tiny switch(white triangle) is the actual electrical trigger to turn camera on and off. Shown in default unpressed position - in this position camera will turn on. Therefore if the black knob (right to the white pointy trinagle) is misaligned then camera will not switch off properly. ORIENTATION - Right side is where EVF seats and hence underneath the accessory shoe and left is where all the USB port etc are located. (photo taken before screw was put back in)

 

Same part from different angle. (photo taken before screw was put back in)

So I just rescrewed all the screws around the dial and made sure the plastic piece in the rotating switch was depressing the electrical switch properly and then reassembled everything again. I did not expect this to work - I actually was planning on doing a deeper disassembly some other time.

Interestingly, this solved the problem. Then I remembered something - when I have the camera with the top part down - sometimes the power switch worked properly. So perhaps the issue was that the switch assembly got loose but when it is upside down it probably lined up properly enough to function as a switch.

In summary: If you have this issue, it may be worthwhile disassembling your camera and ensuring all the screws around the power switch assembly is secured properly. You need to remove EVF piece and mainboard to get access to this area

This is the battery door check switch - same switch is used for the power switch

 

 

태그

,

댓글0